`
空城旧梦why
  • 浏览: 24782 次
  • 性别: Icon_minigender_1
  • 来自: 长沙
社区版块
存档分类
最新评论

poj1007 - DNA Sorting

    博客分类:
  • acm
 
阅读更多
DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 76944   Accepted: 30826

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

 

 
利用string来存储DNA序列然后利用其逆序数从小到大进行排序,输出就行了
下面是我的源代码:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int cal(string s)
{
    int sum=0,i,j,len;
    len=s.size();
    for(i=0;i<len-1;i++)
        for(j=i+1;j<len;j++)
            if(s[i]>s[j])
                sum+=1;
    return sum;
}

bool cmp(string const &s1,string const &s2)
{
    return cal(s1)<cal(s2);
}

int main()
{
    string str[105];
    int n,m,i;
    cin>>n>>m;
    for(i=0;i<m;i++)
        cin>>str[i];
    sort(str,str+m,cmp);
    for(i=0;i<m;i++)
        cout<<str[i]<<endl;
    return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics